CVE-2023-28772

Public on 2023-03-23
Modified on 2024-01-12
Description
An issue was discovered in the Linux kernel before 5.13.3. lib/seq_buf.c has a seq_buf_putmem_hex buffer overflow.
Severity
Important severity
Important
CVSS v3 Base Score
7.8
See breakdown

Affected Packages

Platform Package Release Date Advisory Status
Amazon Linux 1 kernel 2021-09-30 ALAS-2021-1539 Fixed
Amazon Linux 2 - Core kernel 2021-08-04 ALAS2-2021-1696 Fixed
Amazon Linux 2 - Kernel-5.10 Extra kernel 2022-01-20 ALAS2KERNEL-5.10-2022-004 Fixed
Amazon Linux 2 - Kernel-5.4 Extra kernel 2022-01-20 ALAS2KERNEL-5.4-2022-006 Fixed
Amazon Linux 2023 kernel Not Affected

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv3 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H