CVE-2023-3247

Public on 2023-06-17
Modified on 2024-01-12
Description
In PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, 8.2.* before 8.2.7 when using SOAP HTTP Digest Authentication, random value generator was not checked for failure, and was using narrower range of values than it should have. In case of random generator failure, it could lead to a disclosure of 31 bits of uninitialized memory from the client to the server, and it also made easier to a malicious server to guess the client's nonce.
Severity
Medium severity
Medium
CVSS v3 Base Score
5.3
See breakdown

Affected Packages

Platform Package Release Date Advisory Status
Amazon Linux 2 - Php8.0 Extra php 2023-09-06 ALAS2PHP8.0-2023-009 Fixed
Amazon Linux 2 - Php8.1 Extra php 2023-09-06 ALAS2PHP8.1-2023-004 Fixed
Amazon Linux 2 - Php8.2 Extra php 2023-09-06 ALAS2PHP8.2-2023-002 Fixed
Amazon Linux 1 php56 Pending Fix
Amazon Linux 2023 php8.1 2023-08-17 ALAS2023-2023-303 Fixed
Amazon Linux 2023 php8.1 2023-08-31 ALAS2023-2023-325 Fixed

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 5.3 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
NVD CVSSv3 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N