CVE-2023-46813

Public on 2023-10-27
Modified on 2024-01-11
Description
An issue was discovered in the Linux kernel before 6.5.9, exploitable by local users with userspace access to MMIO registers. Incorrect access checking in the #VC handler and instruction emulation of the SEV-ES emulation of MMIO accesses could lead to arbitrary write access to kernel memory (and thus privilege escalation). This depends on a race condition through which userspace can replace an instruction before the #VC handler reads it.
Severity
Important severity
Important
CVSS v3 Base Score
7.0
See breakdown

Affected Packages

Platform Package Release Date Advisory Status
Amazon Linux 1 kernel Not Affected
Amazon Linux 2 - Kernel-5.10 Extra kernel 2023-11-09 ALAS2KERNEL-5.10-2023-043 Fixed
Amazon Linux 2 - Kernel-5.15 Extra kernel 2023-11-09 ALAS2KERNEL-5.15-2023-030 Fixed
Amazon Linux 2023 kernel 2023-11-09 ALAS2023-2023-430 Fixed

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.0 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv3 7.0 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H