CVE-2023-6931

Public on 2023-12-19
Modified on 2024-02-02
Description
A heap out-of-bounds write vulnerability in the Linux kernel's Performance Events system component can be exploited to achieve local privilege escalation.

A perf_event's read_size can overflow, leading to an heap out-of-bounds increment or write in perf_read_group().

We recommend upgrading past commit 382c27f4ed28f803b1f1473ac2d8db0afc795a1b.
Severity
Important severity
Important
CVSS v3 Base Score
7.8
See breakdown

Affected Packages

Platform Package Release Date Advisory Status
Amazon Linux 1 kernel 2024-02-01 ALAS-2024-1912 Fixed
Amazon Linux 2 - Core kernel 2024-02-01 ALAS2-2024-2443 Fixed
Amazon Linux 2 - Kernel-5.10 Extra kernel 2024-01-05 ALAS2KERNEL-5.10-2024-045 Fixed
Amazon Linux 2 - Kernel-5.10 Extra kernel 2024-01-19 ALAS2KERNEL-5.10-2024-047 Fixed
Amazon Linux 2 - Kernel-5.15 Extra kernel 2024-01-05 ALAS2KERNEL-5.15-2024-033 Fixed
Amazon Linux 2 - Kernel-5.15 Extra kernel 2024-01-19 ALAS2KERNEL-5.15-2024-035 Fixed
Amazon Linux 2 - Kernel-5.4 Extra kernel 2024-01-03 ALAS2KERNEL-5.4-2024-057 Fixed
Amazon Linux 2023 kernel Pending Fix

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv3 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H