CVE-2024-21885

Public on 2024-01-18
Modified on 2024-02-28
Description
Heap buffer overflow in XISendDeviceHierarchyEvent

NOTE: https://lists.x.org/archives/xorg/2024-January/061525.html
NOTE: https://gitlab.freedesktop.org/xorg/xserver/-/commit/4a5e9b1895627d40d26045bd0b7ef3dce503cbd1
Severity
Important severity
Important
CVSS v3 Base Score
8.4
See breakdown

Affected Packages

Platform Package Release Date Advisory Status
Amazon Linux 1 xorg-x11-server Pending Fix
Amazon Linux 2 - Core xorg-x11-server 2024-02-15 ALAS2-2024-2455 Fixed
Amazon Linux 2023 xorg-x11-server 2024-02-15 ALAS2023-2024-522 Fixed

CVSS Scores

Score Type Score Vector
Amazon Linux CVSSv3 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
NVD CVSSv3 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H